RotaGeek runs on all modern browsers.

We support Internet Explorer 9 onwards.

We do not support Internet Explorer 8 or below. There are several very good reasons for this.

1) Even Microsoft do not support IE8 or below

2) These early versions have security vulnerabilities

3) IE8 and earlier have limitations that inhibit your utilisation of the full power of our scheduling software (and many other services).

If you have IE8 or below, please upgrade your browser. It will make your life a better place!

Did this answer your question?